feb
6
2014

Outlook 2010 “Calendar Folder property is missing”

Su un outlook 2010 sp2 connesso ad Exchange 2010, un cliente ha un warning ricorrente nell’eventviewer

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Outlook" />
  <EventID Qualifiers="16384">27</EventID>
  <Level>3</Level>
  <Task>0</Task>
  <Keywords>0x80000000000000</Keywords>
  <TimeCreated SystemTime="2014-02-06T09:46:38.000000000Z" />
  <EventRecordID>5385</EventRecordID>
  <Channel>Application</Channel>
  <Computer>nomedelcomputer</Computer>
  <Security />
  </System>
- <EventData>
  <Data>Calendar Folder property is missing</Data>
  </EventData>
  </Event>

La soluzione al problema è l’installazione dell’hotfix relativo KB2849973 un riavvio di Outlook e tutto torna a posto.

gen
28
2014

Come cambiare la lingua di visualizzazione di Outlook delle cartelle principali

L’aggiornamento da un Outlook in una lingua all’Outlook in un’altra lingua, oppure il passaggio ad una struttura basata su Exchange ma situata in una zona con lingua differente può portare ad avere l’Outlook nella lingua desiderata ma le cartelle principali (posta in arrivo, posta inviata, cestino…) nella lingua propria dell’utente che per la prima volta ha acceduto alla casella (ad esempio se l’amministratore ha fatto dal suo pc un accesso alla webmail OWA per verificare il funzionamento di una certa casella, questa prenderà i nomi delle cartelle nella lingua utilizzata dall’amministratore).

Per ottenere i nomi corretti (e quindi per esempio se siamo in inglese inbox, sent items, trash…) è sufficiente chiudere Outlook e lanciarlo dal comando esegui in questo modo:

Outlook.exe /resetfoldernames

Le cartelle principali (main folders) prenderanno il nome nella lingua del client Outlook che ha lanciato la richiesta e rimarranno tali finchè non verrà nuovamente eseguita una operazione di reset dei nomi.

gen
21
2014

Impossibile visualizzare gli attachment in Owa 2003, quando la mail è spedita da Owa 2010

Nella fase di migrazione da Exchange 2003 ad Exchange 2010, durante il periodo di coesistenza, l’invio di una mail da un utente già migrato al sistema 2010 verso un utente ancora sul 2003 eseguita tramite l’interfaccia web genera un funzionamento bizzarro. La mail arriva ma l’allegato non compare. Questo avviene anche utilizzando la mail da dispositivo mobile (iphone, android) che sfruttano appunto web access. Stranamente, accedendo con l’outlook del pc aziendale la mail c’è ed è completa in tutte le sue parti allegato incluso. Dopo un attimo di perplessità, qualche decina di test tra i vari sistemi 2003 (owa, cellulare, outlook locale, outlook rpc over https) e 2010 (owa, mobile, outlook locale e anywhere) una sana googlata mi fa giungere alla soluzione: http://support.microsoft.com/kb/2400041

Si tratta di un problema che nasce dall’utilizzo di silverlight per la fase di aggiunta di un file ad una mail quindi, dice Microsoft, per risolvere il problema basta disabilitare il supporto silverlight sul CAS 2010. Per controllarne lo stato dalla Exchange management Shell si esegue

Get-OwaVirtualDirectory | select Name, Server, SilverLightEnabled

image 

Quindi per modificarne il valore

Get-OwaVirtualDirectory | Set-OwaVirtualDirectory -SilverlightEnabled $false

Poi si riavvia IIS.

Il secondo metodo consigliato da Microsoft è quello di utilizzare un client che non utilizza Silverlight o sul quale Silverlight non è stato installato per la web mail.

Recent Tweets

Note: For Customization and Configuration, CheckOut Recent Tweets Documentation