nov
20
2006

Stranezze Telecom...

Venerdì mi trovo da un Cliente che mi segnala questo problema: "non riesco a scaricare gli aggiornamenti del programma XXX dal sito del produttore".
Provo a ripetere la procedura (si sa che i clienti tendono ad incolpare le macchine) ed effettivamente la procedura fallisce; noto che il link del download redireziona verso un server ftp. Provo ad effettuare un download diretto con filezilla... niente! Sembra proprio che l'ftp non funzioni. Tento da altri pc, niente da fare. La cosa comica è che dal server invece l'ftp funziona! Sembra quasi che il router droppi le connessioni ftp verso l'esterno dai client.
Indago meglio, la rete è basata su un 2003 SBS con client XP tutti SP2. E qui arrivano i primi dubbi: l'ADSL è Alice Business con router Smartgate Pirelli!
Dopo averne lette di tutti i colori su questa astronave, mi ritrovo ad avere un problema quantomeno bizzarro! Sento il 191 dove mi confermano che l'apparecchio è una mezza ciofeca e che se voglio fare le cose per bene dovrei far cambiare abbonamento al cliente convertendolo in una naked o addirittura passare ad interbusiness. Morale della favola una bella chiacchierata ma nessuna soluzione al problema!

In pausa pranzo spengo il server, tutti i client e connetto un pc non appartenente al dominio. Tento di fare un ftp su ftp.microsoft.com, ovviamente non se ne parla! Allora decido di assegnare "temporaneamente" al pc l'IP del server... magicomagilla funziona tutto! Strano no? la configurazione del cliente è la presente:

gateway 192.168.1.1 pirelli smartgate (NAPT dal 192.168.1.2 al 192.168.1.253 Virtual Server configurato su un paio di porte ma disabilitato)
server 192.168.1.2 2003 SBS
client 192.168.1.100-200 DHCP
Sembra così strano?!?! Ancora di più quando uno dei soci mi assicura che fino a poco tempo fa poteva tranquillamente scaricare gli aggiornamenti!

Ora sono in attesa di sentire Telecom per vedere se ho la fortuna di parlare con qualcuno che è davvero un tecnico e non un telefonista venditore di servizi!
Gli ottimi suggerimenti di Andrea Beggi sono stati di provare a sniffare la rete con Ethereal o provare mettere un firewall sull'ip funzionante e nattarci dietro tutta la rete (ovviamente questo vuol dire perdere tempo e cambiare tutta la subnet della LAN, senza la garanzia che il problema sia risolto e soprattutto senza garanzia che il cliente riconosca il lavoro svolto). Proverò sicuramente con Ethereal quanto prima.
Terrò aggiornato questo post con i risultati dell'intervento.

Add comment

biuquote
  • Comment
  • Preview
Loading

Recent Tweets

Note: For Customization and Configuration, CheckOut Recent Tweets Documentation